summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1450b150bd1..fe6891dc2bd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,21 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=artanis
-pkgver=0.2.1
-pkgrel=3
+pkgver=0.2.3
+pkgrel=1
pkgdesc="A fast monolithic web-framework of Scheme"
url="http://web-artanis.com/"
depends=('guile')
arch=('x86_64')
license=('GPL')
source=("http://ftp.gnu.org/gnu/$pkgname/$pkgname-${pkgver}.tar.bz2")
-md5sums=('a0ea29f97545e1a49e7e96441cb6eb2f')
+md5sums=('f5a074d04805d6538a32640d1edd204a')
options=('!strip')
+prepare() {
+ sed -i '/bash_completion/d' $pkgname-$pkgver/Makefile.in
+}
+
build() {
cd $pkgname-$pkgver
GUILE_EFFECTIVE_VERSION=2.2 ./configure --prefix=/usr
@@ -29,6 +33,6 @@ package() {
cd $pkgname-$pkgver
make DESTDIR=$pkgdir install
# repair
- cp -r $pkgdir/{share,bin} $pkgdir/usr
- rm -r $pkgdir/{share,bin}
+ cp -r "$pkgdir"/{share,bin} "$pkgdir"/usr
+ rm -r "$pkgdir"/{share,bin}
}