summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59ea0d314078..ad63aab1cbe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ fi
# Uncomment for a debug build
#_qmake_args="CONFIG+=debug"
pkgname=artriculate
-pkgver=0.4
+pkgver=0.4.r0.g9d27639
pkgrel=1
pkgdesc='QML box2d application for displaying artwork'
arch=('any')
@@ -22,10 +22,16 @@ url='https://github.com/sirspudd/artriculate'
license=('GPL3')
makedepends=("qt-sdk-raspberry-pi${_piver}")
depends=('qt-sdk-raspberry-pi-target-libs')
-source=("git://github.com/sirspudd/artriculate#tag=${pkgver}")
+source=("git://github.com/sirspudd/artriculate")
sha256sums=('SKIP')
options=('!strip')
+pkgver () {
+ cd "$srcdir/$pkgname"
+
+ git describe --tags --long | sed -r 's/^v//;s/-RC/RC/;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
build() {
cd "$srcdir"/"$pkgname"
$_qmake
@@ -35,13 +41,11 @@ build() {
package() {
local _repo_src=${srcdir}/${pkgname}
local _systemd_deploy_path=${pkgdir}/usr/lib/systemd/system
- local _qml_deploy_path=${pkgdir}/usr/share/${pkgname}
local _bin_path=${pkgdir}/usr/bin
mkdir -p $_systemd_deploy_path $_qml_deploy_path $_bin_path
cp ${_repo_src}/artriculate $_bin_path
cp ${_repo_src}/src/resources/*.service ${_systemd_deploy_path}
- cp -r ${_repo_src}/qml ${_qml_deploy_path}
cd ${_repo_src}
INSTALL_ROOT="$pkgdir" make install