summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2feaa3c8b022..ea330dd86cb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=asciigraph
-pkgver=0.4.1
-pkgrel=4
+pkgver=0.5.1
+pkgrel=1
pkgdesc="Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies"
arch=('x86_64')
url='https://github.com/guptarohit/asciigraph'
license=('BSD')
-depends=('glibc')
makedepends=('go')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/guptarohit/asciigraph/archive/v${pkgver}.tar.gz")
-sha256sums=('5f8dc2e2dcfb253ebc0b23e824a590ae38e20a4d180393d175e25fa0f21d547d')
+sha256sums=('2149a341868f128c78a997a93a37baf99fd8080dfe3e6219fe9370febc6a05f5')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -24,6 +23,9 @@ build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOPATH="${srcdir}"/go
+ export PATH=$PATH:$GOPATH/bin
+ go get -d -v ./...
go build -o build ./cmd/...
}
@@ -31,4 +33,4 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm755 build/asciigraph "${pkgdir}/usr/bin/asciigraph"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/asciigraph/LICENSE"
-} \ No newline at end of file
+}