summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f47f2cdd876..d7182682e4e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
-# Maintainer: ianux <ianux@free.fr>
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: ianux <ianux@free.fr>
pkgname=asdcplib
-pkgver=1.12.60
+pkgver=2.10.35
pkgrel=1
-pkgdesc="open source implementation of SMPTE and the MXF Interop “Sound & Picture Track File” format"
+pkgdesc="Open Source implementation of SMPTE and the MXF Interop “Sound & Picture Track File” format"
arch=('i686' 'x86_64')
url="http://www.cinecert.com/asdcplib/"
-license=('GPL3')
+license=('GPL-3.0')
depends=('expat' 'openssl')
-source=(http://download.cinecert.com/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-sha1sums=('427268c3070827af63e067ff4d87aa32fe26ac1d')
+source=("https://github.com/cinecert/asdcplib/archive/rel_2_10_35.tar.gz")
+md5sums=('4639926c64c1c752ad4f1550f6a025c2')
build() {
- cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr
+ cd ${pkgname}-rel_2_10_35
+ autoreconf -if
+ ./configure --enable-freedist --enable-as-02 --prefix=/usr
make
+ make dist
}
package() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname}-rel_2_10_35
make DESTDIR=${pkgdir} install
-}
-
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file