summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cb4689fac72..2d8d1b06bb45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=aseprite
pkgver=1.2.7.2
-pkgrel=1
+pkgrel=2
pkgdesc='Create animated sprites and pixel art'
arch=('x86_64' 'i686')
url="http://www.aseprite.org/"
@@ -30,7 +30,12 @@ build() {
mkdir -p build && cd build
# CMake config notes:
- # Do not build using the shared allegro4. Weird graphical glitches happen when linking to the library from the official repo
+ # Do not build using the shared allegro4. Weird graphical glitches happen
+ # when linking to the library from the official repo. Also, since loadpng.h
+ # is also distributed in allegro4, using that shared library must also be
+ # disabled since there's no guarantee Arch users might have allegro4
+ # installed.
+
cmake -DUSE_SHARED_PIXMAN=ON \
-DWITH_WEBP_SUPPORT=ON \
@@ -41,12 +46,12 @@ build() {
-DUSE_SHARED_HARFBUZZ=ON \
-DUSE_SHARED_ZLIB=ON \
-DUSE_SHARED_LIBPNG=ON \
- -DUSE_SHARED_LIBLOADPNG=ON \
-DUSE_SHARED_TINYXML=ON \
-DUSE_SHARED_CMARK=ON \
-DENABLE_UPDATER=OFF \
-DUSE_SHARED_FREETYPE=ON \
-DUSE_SHARED_ALLEGRO4=OFF \
+ -DUSE_SHARED_LIBLOADPNG=OFF \
-DCMAKE_INSTALL_PREFIX:STRING=/usr ..
make $MAKEFLAGS