summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD104
1 files changed, 50 insertions, 54 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 105c5769a6f0..b444115dbdb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,50 +7,56 @@
# Contributor: Kamil BiduĊ› <kamil.bidus@gmail.com>
pkgname=aseprite
-pkgver=1.2.16.2
-pkgrel=3
+pkgver=1.2.17
+pkgrel=1
pkgdesc='Create animated sprites and pixel art'
-arch=('x86_64' 'i686')
+arch=('x86_64')
url="http://www.aseprite.org/"
license=('custom')
-depends=('cmark' 'pixman' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2'
- 'harfbuzz' 'nettle' 'fontconfig' 'libxcursor' 'desktop-file-utils' 'hicolor-icon-theme')
+depends=('cmark' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2'
+ 'harfbuzz' 'nettle' 'fontconfig' 'libxcursor' 'hicolor-icon-theme')
makedepends=('cmake' 'ninja' 'git' 'python2')
conflicts=("aseprite-git" "aseprite-gpl" "skia-git")
source=("https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/${pkgname^}-\
v${pkgver}-Source.zip"
"${pkgname}.desktop"
"git+https://chromium.googlesource.com/chromium/tools/depot_tools.git"
-"git+https://github.com/${pkgname}/skia.git#branch=${pkgname}-m71"
+"git+https://github.com/${pkgname}/skia.git#branch=${pkgname}-m81"
"git+https://chromium.googlesource.com/chromium/buildtools.git\
#commit=505de88083136eefd056e5ee4ca0f01fe9b33de8"
"git+https://skia.googlesource.com/common.git#commit=9737551d7a52c3db3262db5856e6bcd62c462b92"
"angle2::git+https://chromium.googlesource.com/angle/angle.git\
-#commit=956ab4d9fab36be9929e63829475d4d69b2c681c"
+#commit=ee07cb317579dfda40dabb5d6d9c209e0e9e0643"
+"git+https://dawn.googlesource.com/dawn.git#commit=604072bc2ed01018eb03bcbbf9d94042f679af63"
"git+https://android.googlesource.com/platform/external/dng_sdk.git\
-#commit=96443b262250c390b0caefbf3eed8463ba35ecae"
+#commit=c8d0c9b1d16bfda56f15165d39e0ffa360a11123"
"egl-registry::git+https://skia.googlesource.com/external/github.com/KhronosGroup/EGL-Registry\
#commit=a0bca08de07c7d7651047bedc0b653cfaaa4f2ae"
-"git+https://android.googlesource.com/platform/external/expat.git#tag=android-6.0.1_r55"
+"git+https://android.googlesource.com/platform/external/expat.git\
+#commit=e5aa0a2cb0a5f759ef31c0819dc67d9b14246a4a"
"freetype::git+https://skia.googlesource.com/third_party/freetype2.git\
-#commit=7edc937fe679d14d66f55cf6f7fa607925d38f3c"
-"git+https://android.googlesource.com/platform/external/googletest\
-#commit=dd43b9998e9a44a579a7aba6c1309407d1a5ed95"
-"git+https://skia.googlesource.com/third_party/harfbuzz.git#tag=1.4.2"
+#commit=0a3d2bb99b45b72e1d45185ab054efa993d97210"
+"git+https://chromium.googlesource.com/external/github.com/harfbuzz/harfbuzz.git\
+#commit=3a74ee528255cc027d84b204a87b5c25e47bff79"
"git+https://chromium.googlesource.com/chromium/deps/icu.git\
-#commit=ec9c1133693148470ffe2e5e53576998e3650c1d"
+#commit=dbd3825b31041d782c5b504c59dcfb5ac7dda08c"
"git+https://skia.googlesource.com/external/github.com/ocornut/imgui.git\
-#commit=bc6ac8b2aee0614debd940e45bc9cd0d9b355c86"
-"git+https://chromium.googlesource.com/external/github.com/open-source-parsers/jsoncpp.git\
-#tag=1.0.0"
-"git+https://skia.googlesource.com/external/github.com/libjpeg-turbo/libjpeg-turbo.git#tag=2.0.0"
-"git+https://skia.googlesource.com/third_party/libpng.git#tag=v1.6.33"
-"git+https://chromium.googlesource.com/webm/libwebp.git#tag=v0.6.1"
-"git+https://skia.googlesource.com/external/github.com/lua/lua.git#tag=v5-3-4"
+#commit=d38d7c6628bebd02692cfdd6fa76b4d992a35b75"
+"git+https://skia.googlesource.com/libgifcodec#commit=38d9c73f49b861bb4a9829371ac311544b120023"
+"git+https://skia.googlesource.com/external/github.com/libjpeg-turbo/libjpeg-turbo.git\
+#commit=574f3a772c96dc9db2c98ef24706feb3f6dbda9a"
+"git+https://skia.googlesource.com/third_party/libpng.git\
+#commit=386707c6d19b974ca2e3db7f5c61873813c6fe44"
+"git+https://chromium.googlesource.com/webm/libwebp.git\
+#commit=0fe1a89dbf1930fc2554dbe76adad5d962054ead"
+"git+https://skia.googlesource.com/external/github.com/lua/lua.git\
+#commit=e354c6355e7f48e087678ec49e340ca0696725b1"
"microhttpd::git+https://android.googlesource.com/platform/external/libmicrohttpd\
#commit=748945ec6f1c67b7efc934ab0808e1d32f2fb98d"
"opencl-lib::git+https://skia.googlesource.com/external/github.com/GPUOpen-Tools/\
common-lib-amd-APPSDK-3.0#commit=4e6d30e406d2e5a65e1d65e404fe6df5f772a32b"
+"opencl-registry::git+https://skia.googlesource.com/external/github.com/KhronosGroup/\
+OpenCL-Registry#commit=932ed55c85f887041291cef8019e54280c033c35"
"opengl-registry::git+https://skia.googlesource.com/external/github.com/KhronosGroup/\
OpenGL-Registry#commit=14b80ebeab022b2c78f84a573f01028c96075553"
"git+https://android.googlesource.com/platform/external/piex.git\
@@ -58,20 +64,22 @@ OpenGL-Registry#commit=14b80ebeab022b2c78f84a573f01028c96075553"
"git+https://skia.googlesource.com/third_party/sdl\
#commit=5d7cfcca344034aff9327f77fc181ae3754e7a90"
"git+https://chromium.googlesource.com/external/github.com/googlei18n/sfntly.git\
-#commit=b18b09b6114b9b7fe6fc2f96d8b15e8a72f66916"
+#commit=b55ff303ea2f9e26702b514cf6a3196a2e3e2974"
+"spirv-cross::git+https://chromium.googlesource.com/external/github.com/KhronosGroup/\
+SPIRV-Cross#commit=53ab2144b90abede33be5161aec5dfc94ddc3caf"
"spirv-headers::git+https://skia.googlesource.com/external/github.com/KhronosGroup/\
-SPIRV-Headers.git#commit=661ad91124e6af2272afd00f804d8aa276e17107"
+SPIRV-Headers.git#commit=29c11140baaf9f7fdaa39a583672c556bf1795a1"
"spirv-tools::git+https://skia.googlesource.com/external/github.com/KhronosGroup/SPIRV-Tools.git\
-#commit=e9e4393b1c5aad7553c05782acefbe32b42644bd"
+#commit=0c4feb643b89d1792b02f7cbef315e9d95633bd7"
"swiftshader::git+https://swiftshader.googlesource.com/SwiftShader\
-#commit=d6126aea667e37d2d7b57b0a381b9f26912a21b7"
+#commit=430def835f9f85d52f4a96db9b715cd9a7403c9c"
+"git+https://skia.googlesource.com/external/github.com/google/wuffs.git\
+#commit=4080840928c0b05a80cda0d14ac2e2615f679f1a"
"git+https://chromium.googlesource.com/chromium/src/third_party/zlib\
#commit=ea3ba903faac98b64b2bf8de5e98cd97b335a474"
-"git+https://github.com/2d-inc/Nima-Cpp.git#commit=4bd02269d7d1d2e650950411325eafa15defb084"
-"git+https://github.com/2d-inc/Nima-Math-Cpp.git#commit=e0c12772093fa8860f55358274515b86885f0108"
-"gn::https://chromium-gn.storage-download.googleapis.com/2f27ff0b6118e5886df976da5effa6003d19d1ce"
+"gn::https://chromium-gn.storage-download.googleapis.com/3523d50538357829725d4ed74b777a572ce0ac74"
)
-sha256sums=('3539c49da702d1ade71d6b5e5a3c495dd5d42c58ae88308b4a3288f93ac522bd'
+sha256sums=('698fb3f667f643869995f2a2d615561ec23cf03c1362895f90ebcc29ed8c1fc1'
'deaf646a615c79a4672b087562a09c44beef37e7acfc6f5f66a437d4f3b97a25'
'SKIP'
'SKIP'
@@ -103,6 +111,7 @@ sha256sums=('3539c49da702d1ade71d6b5e5a3c495dd5d42c58ae88308b4a3288f93ac522bd'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'c482981e91b5591ff85e055f3026956d6178aae3560ed984ff60b22e99351312')
prepare() {
@@ -116,9 +125,9 @@ prepare() {
mv --force --no-target-directory --verbose "${_dep}" "skia/${_dep}"
done
- for _dep in angle2 dng_sdk egl-registry expat freetype googletest harfbuzz icu imgui jsoncpp \
- libjpeg-turbo libpng libwebp lua microhttpd opencl-lib opengl-registry piex sdl \
- sfntly spirv-headers spirv-tools swiftshader zlib Nima-Cpp Nima-Math-Cpp
+ for _dep in angle2 dawn dng_sdk egl-registry expat freetype harfbuzz icu imgui opencl-registry \
+ libjpeg-turbo libpng libwebp lua microhttpd opencl-lib opengl-registry piex \
+ sdl sfntly spirv-cross spirv-headers spirv-tools swiftshader zlib wuffs
do
mv --force --no-target-directory --verbose "${_dep}" "skia/third_party/externals/${_dep}"
done
@@ -128,12 +137,9 @@ prepare() {
cp --verbose skia/bin/gn skia/buildtools/linux64/gn
# Skia assumes python is linked to python2, not python3
- # Also, running ninja from depot_tools seems to cause problems
mkdir --parents --verbose binsub
cd binsub
ln --force --symbolic --verbose /usr/bin/python2 python
- ln --force --symbolic --verbose /usr/bin/python2-config python-config
- ln --force --symbolic --verbose /usr/bin/ninja
}
build() {
@@ -142,17 +148,16 @@ build() {
# Build skia
_skiapath="${srcdir}/binsub:${srcdir}/depot_tools:${PATH}"
cd skia
- PATH="${_skiapath}" gn gen out/Release --args="is_debug=false is_official_build=true\
- skia_use_system_expat=false skia_use_system_icu=false skia_use_system_libjpeg_turbo=false\
+ PATH="${_skiapath}" gn gen out/Release-x64 --args="is_debug=false is_official_build=true \
+ skia_use_system_expat=false skia_use_system_icu=false skia_use_system_libjpeg_turbo=false \
skia_use_system_libpng=false skia_use_system_libwebp=false skia_use_system_zlib=false"
- PATH="${_skiapath}" ninja -C out/Release skia
+ PATH="${_skiapath}" ninja -C out/Release-x64 skia modules
# Build aseprite
cd "${srcdir}"
mkdir --parents --verbose build && cd build
cmake \
- -DUSE_SHARED_PIXMAN=ON \
-DWITH_WEBP_SUPPORT=ON \
-DUSE_SHARED_CURL=ON \
-DUSE_SHARED_GIFLIB=ON \
@@ -166,25 +171,24 @@ build() {
-DUSE_SHARED_FREETYPE=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DLAF_OS_BACKEND=skia \
+ -DLAF_BACKEND=skia \
-DSKIA_DIR="${srcdir}/skia" \
- -DSKIA_OUT_DIR="${srcdir}/skia/out/Release" \
+ -DSKIA_LIBRARY_DIR="${srcdir}/skia/out/Release-x64" \
-G Ninja \
..
- cmake --build .
+ ninja aseprite
}
package() {
cd "${srcdir}"/build
- DESTDIR="${pkgdir}" cmake --install .
+ install -D --verbose "bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
# Aseprite, by default, doesn't install a few files on its own. So, they are installed manually.
- cp --recursive --verbose 'bin/data/docs' "${pkgdir}/usr/share/aseprite/data"
- install --mode=644 --verbose 'bin/data/README.md' "${pkgdir}/usr/share/aseprite/data"
- install --mode=644 --verbose 'bin/data/EULA.txt' "${pkgdir}/usr/share/aseprite/data"
+ install --directory --verbose "${pkgdir}/usr/share/${pkgname}/data"
+ cp --recursive --verbose 'bin/data' "${pkgdir}/usr/share/${pkgname}"
install --directory --verbose "${pkgdir}/usr/share/doc/${pkgname}"
cp --recursive --verbose '../docs' "${pkgdir}/usr/share/doc/${pkgname}"
@@ -203,14 +207,6 @@ package() {
install -D --mode=644 --verbose --target-directory "${pkgdir}/usr/share/licenses/${pkgname}" \
'bin/data/EULA.txt'
install --mode=644 --verbose '../docs/LICENSES.md' "${pkgdir}/usr/share/licenses/${pkgname}"
-
- # Remove conflicting files with libarchive
- # TODO: With the current compilation options, looks like aseprite build process builds these
- # binaries. Disable the compilation of the following files later on:
- # Note: Github issue: https://github.com/aseprite/aseprite/issues/1602
- rm --verbose "${pkgdir}/usr/bin/"{bsdcat,bsdcpio,bsdtar,img2webp}
- rm --recursive --verbose "${pkgdir}/usr/include" "${pkgdir}/usr/lib" "${pkgdir}/usr/share/WebP" \
- "${pkgdir}/usr/share/man"
}
# vim:set ts=2 sw=2 et: