summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db9a36e95450..6106f1fdf7ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Brett Dutro <brett.dutro@gmail.com>
pkgname=ashuffle-git
-pkgver=3.4.0.r3.g9e4b7a1
+pkgver=3.13.0.r2.gfccccdd
pkgrel=1
pkgdesc="Automatic library-wide shuffle for mpd. (git)"
url="https://github.com/joshkunz/ashuffle"
@@ -20,8 +20,12 @@ source=(
"git+https://github.com/joshkunz/${pkgname%-git}.git"
"git+https://github.com/abseil/abseil-cpp.git"
"git+https://github.com/google/googletest.git"
+ "0001_add_option_to_use_system_yaml_cpp.patch"
+)
+sha256sums=(
+ 'SKIP' 'SKIP' 'SKIP'
+ "b2b3515daf31a886bf33119276f1b968353f5ac18e353bbc39ae05c6164d47e1"
)
-md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -31,6 +35,8 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
+ patch -p1 -i "${srcdir}/0001_add_option_to_use_system_yaml_cpp.patch"
+
git submodule init
git config submodule."subprojects/absl".url "${srcdir}/abseil-cpp"
git config submodule."subprojects/googletest".url "${srcdir}/googletest"
@@ -40,7 +46,10 @@ prepare() {
build() {
cd "ashuffle"
- arch-meson -Dtests=enabled builddir
+ arch-meson \
+ -Dtests=enabled \
+ -Dunsupported_use_system_yaml_cpp=true \
+ builddir
ninja -C builddir
}