summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f7ce0da1c57..92130b87d751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,23 @@
# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
pkgname=aspcud
-pkgver=1.9.4
-pkgrel=4
+pkgver=1.9.6
+pkgrel=1
pkgdesc='Solver for package dependencies'
arch=('x86_64')
url='https://potassco.org/aspcud'
license=('GPL3')
makedepends=('boost' 'cmake' 'git' 'ninja' 're2c')
depends=('clingo')
-source=("git+https://github.com/potassco/$pkgname#tag=v$pkgver")
-md5sums=('SKIP')
+source=("https://github.com/potassco/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('4dddfd4a74e4324887a1ddd7f8ff36231774fc1aa78b383256546e83acdf516c')
build() {
mkdir -p build
cd build
- cmake "../$pkgname" \
+ cmake "../${pkgname}-${pkgver}" \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_INSTALL_LIBDIR:PATH=lib \
- -DCUDF2LP_LOC=cudf2lp \
- -DGRINGO_LOC=gringo \
- -DCLASP_LOC=clasp \
-DCMAKE_BUILD_TYPE=Release \
-GNinja
ninja