summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5eace2eef6a3..62013f0aadef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=assh-git
_pkgname=assh
pkgver=2.10.0.r0.g1ff23bee
-pkgrel=1
+pkgrel=2
pkgdesc='make your ssh client smarter https://manfred.life/assh'
arch=('any')
url='https://github.com/moul/assh.git'
@@ -21,9 +21,13 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
+ version=$(git describe --tags --always)
+ vcs_ref=$(git rev-parse --short HEAD)
GOPATH=${srcdir} \
GO111MODULE=on \
- go build -modcacherw -o assh
+ go build \
+ --ldflags "-X moul.io/assh/v2/pkg/version.Version=$version -X moul.io/assh/v2/pkg/version.VcsRef=$vcs_ref" \
+ -modcacherw -o assh
}
package() {