summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 153e878b7315..459a65c8c6a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Wren Baxter <aur [at] wren.dev>
pkgname=astap-bin-qt5
-pkgver=2023.05.31
-pkgrel=2
+pkgver=2023.06.08
+pkgrel=1
pkgdesc="Astrometric (plate) solver, stacking of images, photometry and FITS viewer"
provides=('astap')
-conflicts=('astap-bin')
-arch=('x86_64') # no 32-bit version provided
+conflicts=('astap-bin' )
+arch=('x86_64') # no 32-bit version provided, consider building from source with the `astap` package
url="https://www.hnsky.org/astap.htm"
license=('LGPL3')
source=("astap-${pkgver}.tar.gz::https://github.com/wrenby/astap-backups/raw/285daf3c41d9cc69732d201c11d59164b77076bf/astap_amd64_qt5.tar.gz")
@@ -19,11 +19,13 @@ makedepends=('tar') # but gnu tar is just fine
# these databases aren't hard-limited by the bounds provided here
# databases can identify 100% of the sky in the ranges provided,
# but can also identify some regions of the sky with FOVs smaller or larger than the given bounds
-optdepends=('hyperleda-galaxy-db-astap: database of 1.3m galaxies and 171k other non-star objects'
- 'w08-star-db-astap: database of stars up to magnitude 8, reliable above 20° FOV'
- 'v17-photometry-color-db-astap: color database of stars up to magnitude 17, reliable with 1-20° FOV, slower but required for photometry'
- 'h17-star-db-astap: database of stars up to magnitude 17, reliable with 1-10° FOV'
- 'h18-star-db-astap: database of stars up to magnitude 18, reliable with 0.25-10° FOV')
+# there is no downside to choosing d50 compared to d05, other than the larger file size
+# the new g05 database covering the 10-20° gap does not yet have an associated package on the AUR
+optdepends=('hyperleda-galaxy-db-astap: 25MB database of 1.3m galaxies and 171k other non-star objects'
+ 'w08-star-db-astap: 250KB database of stars up to magnitude 8, reliable above 20° FOV'
+ 'd05-star-db-astap: 100MB database of 500 stars per square degree, reliable with 0.6-10° FOV'
+ 'd20-star-db-astap: 400MB database of 2000 stars per square degree, reliable with 0.3-10° FOV'
+ 'd50-star-db-astap: 900MB database of 5000 stars per square degree, reliable with 0.2-10° FOV')
prepare() {
tar xpf "astap-${pkgver}.tar.gz"
@@ -33,4 +35,3 @@ package() {
cp -r "${srcdir}"/opt "${pkgdir}"/opt
cp -r "${srcdir}"/usr "${pkgdir}"/usr
}
-