summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30675c9f3824..eca3abf01d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=3.7
+pkgver=4.0.0
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -11,19 +11,16 @@ depends=('gcc-libs')
makedepends=('git' 'cmake' 'python')
source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
'git+https://github.com/google/googletest.git'
- '010-astc-encoder-fix-install.patch'
- '020-astc-encoder-use-shared-library.patch')
+ '010-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- '5f14b7a802b0548cdaa05238964d3a0181ea43961782500f7611e6ae9203bf92'
- 'e64fe99e5dc5f014156f58eb7ea179c922cafd71fecbd704c86ebaa3b04ed9e6')
+ 'dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
git -C astc-encoder submodule update
- patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-fix-install.patch"
- patch -d astc-encoder -Np1 -i "${srcdir}/020-astc-encoder-use-shared-library.patch"
+ patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-use-shared-library.patch"
}
build() {
@@ -47,4 +44,5 @@ package() {
install -D -m644 astc-encoder/Source/astcenc.h -t "${pkgdir}/usr/include"
ln -s astcenc-sse2 "${pkgdir}/usr/bin/astcenc"
ln -s libastcenc-sse2.so "${pkgdir}/usr/lib/libastcenc.so"
+ rm "${pkgdir}/usr/bin"/test-unit*
}