summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1c2e7f2497f..812f769b4142 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Byron Torres <b at torresjrjr dot com>
pkgname=astronaut-git
-pkgver=0.1.0.r2.g762f8a6
+pkgver=0.1.2.r1.g3f41b58
pkgrel=1
pkgdesc="Gemini browser for the terminal"
arch=('x86_64')
-url="https://git.sr.ht/~adnano/astronaut"
+url="https://sr.ht/~adnano/astronaut"
license=('GPL3')
depends=('glibc')
makedepends=('git' 'go' 'scdoc')
options=('!lto')
source=(
- "$pkgname::git+$url"
- 'Makefile.patch')
-sha256sums=('SKIP'
- '8e1d4bb411d3d678a9feb4bcfc53954279ebe0fb4c3a4583a3b7a541c05edcd2')
+ "$pkgname::git+https://git.sr.ht/~adnano/astronaut#branch=master"
+ 'Makefile.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '8e1d4bb411d3d678a9feb4bcfc53954279ebe0fb4c3a4583a3b7a541c05edcd2'
+)
pkgver() {
git -C "$pkgname" describe --long --tags | sed 's/-/.r/;s/-/./'
@@ -22,7 +25,6 @@ pkgver() {
prepare() {
cd "$pkgname"
- patch -p1 < "$srcdir/Makefile.patch"
go mod tidy
}
@@ -34,11 +36,10 @@ build() {
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
cd "$pkgname"
- ./configure --prefix=/usr
make
}
package() {
cd "$pkgname"
- make DESTDIR="$pkgdir/" install
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
}