summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09c9d505c79f..aa94025d27aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: FadeMind <fademind@gmail.com>
pkgname=asus-nb-wmi-reload-git
-pkgver=20160312
+pkgver=20160528
pkgrel=1
pkgdesc="Systemd service for reload Asus Notebooks WMI Hotkey Driver after resume for restoring light on WLAN LED"
arch=('any')
-url="https://github.com/FadeMind/${pkgname/-git/}"
+url="https://github.com/FadeMind/${pkgname%-git}"
license=('GPL2')
depends=('bash'
'kmod'
'systemd')
-makedepends=('git')
-source=("${pkgname/-git/}::git+${url}.git")
+makedepends=('git' 'make')
+source=("${pkgname%-git}::git+${url}.git")
sha256sums=('SKIP')
-install="${pkgname/-git/}.install"
+install="${pkgname%-git}.install"
pkgver() {
- cd ${pkgname/-git/}
+ cd ${pkgname%-git}
git log -1 --format="%cd" --date=short | tr -d '-'
}
package() {
- install -Dm644 "${pkgname/-git/}/${pkgname/-git/}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname/-git/}.service"
- install -Dm755 "${pkgname/-git/}/${pkgname/-git/}" "${pkgdir}/usr/bin/${pkgname/-git/}"
+ cd ${pkgname%-git}
+ make install DESTDIR="$pkgdir"
}