summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 802b069ce1f1..705f6cfd9410 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: smallst <smallst@smallst.cn>
-# Maintainer: LinRs <LinRs AT users.noreply.github.com>
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: smallst <smallst@smallst.cn>
+# Contributor:: LinRs <LinRs AT users.noreply.github.com>
# Contributor: Eric Bélanger <eric@archlinux.org>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor:: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=auctex
-pkgver=12.3
+pkgver=13.1
pkgrel=1
pkgdesc="An extensible package for writing and formatting TeX files in Emacs"
arch=('any')
@@ -11,23 +13,23 @@ url="https://www.gnu.org/software/auctex/"
license=('GPL3')
depends=('emacs' 'ghostscript' 'texlive-core')
install=auctex.install
-source=("https://ftp.gnu.org/pub/gnu/auctex/${pkgname}-${pkgver}.tar.gz"{,.sig})
-sha256sums=('2fd4fe30b69457c9277fe204d3e83c8472bcf500c8fe4a810d744406174ca9dd'
+source=("https://ftp.gnu.org/pub/gnu/auctex/$pkgname-$pkgver.tar.gz"{,.sig})
+sha256sums=('2b797e0eaf8e657aa7d4baa5a99badad683d1ffdc1b7c58ced9f2aa02eabcda8'
'SKIP')
-validpgpkeys=('70CDE487C45540307F86972BE2FD58BF20485F50') #Mosè Giordano <mose@gnu.org>
+validpgpkeys=('70CDE487C45540307F86972BE2FD58BF20485F50') # Mosè Giordano <mose@gnu.org>
prepare() {
- cd ${pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
sed -i 's/as_fn_error $? "--with-texmf-dir=/echo as_fn_error $? "--with-texmf-dir=/' configure
}
build() {
- cd ${pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
./configure --prefix=/usr --localstatedir=/var --with-texmf-dir=/usr/share/texmf
make
}
package() {
- cd ${pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
make DESTDIR="${pkgdir}" install
}