summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ff0acb5fc14..ab15d70968f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# $Id$
# Maintainer: Radioactiveman <thomas-lange2@gmx.de>
# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Alexander Fehr <pizzapunk gmail com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
-# To enable Qt support, uncomment the additional dependencies and "--enable-qt".
-# Do the same with audacious-plugins-git. Then run Audacious by "audacious --qt".
+# To enable GTK support, uncomment the additional dependency and "--enable-gtk".
+# Do the same with audacious-plugins-git. Then run Audacious by "audacious --gtk".
-pkgname=audacious-git
-pkgver=2019.02.24
+_pkgname=audacious
+pkgname="$_pkgname-git"
+pkgver=2019.10.24
pkgrel=1
pkgdesc="Lightweight, advanced audio player focused on audio quality"
arch=('i686' 'x86_64')
url="https://audacious-media-player.org/"
license=('BSD')
-depends=('gtk2' 'libsm' 'gnome-icon-theme' 'desktop-file-utils') # 'qt5-base')
-makedepends=('python2' 'git') # for gdbus-codegen
+depends=('glib2' 'qt5-base') # 'gtk2')
+makedepends=('git' 'python') # for gdbus-codegen
optdepends=('unzip: zipped skins support')
-provides=('audacious')
-conflicts=('audacious')
-install=$pkgname.install
-source=('git://github.com/audacious-media-player/audacious.git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install="$_pkgname.install"
+source=("git://github.com/audacious-media-player/$_pkgname.git")
sha256sums=('SKIP')
pkgver() {
@@ -29,19 +29,19 @@ pkgver() {
}
build() {
- cd "$srcdir/audacious"
+ cd "$srcdir/$_pkgname"
autoreconf -I m4
./configure \
--prefix=/usr \
--with-buildstamp="$(date +%x)" \
- # --enable-qt \
+ # --enable-gtk \
make
}
package() {
- cd "$srcdir/audacious"
+ cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/audacious/LICENSE"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}