summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 23 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ade7d6f9c58..54d65be34c1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,12 @@
# Contributor: Alexander Fehr <pizzapunk gmail com>
# Contributor: William Rea <sillywilly@gmail.com>
+# Set to 1 to use Meson build system
+_use_meson=0
+
_pkgname=audacious-plugins
pkgname="$_pkgname-git"
-pkgver=4.0.beta1.r215.g6d8a86d3d
+pkgver=4.0.beta1.r265.gffa26ceb1
pkgrel=1
epoch=1
pkgdesc="Plugins for Audacious (git version)"
@@ -24,6 +27,10 @@ makedepends=('glib2' 'python' 'git')
source=("git://github.com/audacious-media-player/$_pkgname.git")
sha256sums=('SKIP')
+if [ "$_use_meson" = 1 ]; then
+ makedepends+=('meson')
+fi
+
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/^audacious-plugins-//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -32,13 +39,24 @@ pkgver() {
build() {
cd "$_pkgname"
- autoreconf -I m4
- ./configure --prefix=/usr
- make
+ if [ "$_use_meson" = 1 ]; then
+ arch-meson build
+ meson compile -C build
+ else
+ autoreconf -I m4
+ ./configure --prefix=/usr
+ make
+ fi
}
package() {
cd "$_pkgname"
- make DESTDIR="$pkgdir" install
+
+ if [ "$_use_meson" = 1 ]; then
+ DESTDIR="$pkgdir" meson install -C build
+ else
+ make DESTDIR="$pkgdir" install
+ fi
+
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}