summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8afc433dc31e..edfb0af3054c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,15 @@ pkgdesc='Cross-distribution Linux wheels'
arch=(any)
url="https://github.com/pypa/auditwheel"
license=(MIT)
-depends=(python python-pyelftools)
-makedepends=('python-pip')
-_wheel="$pkgname-$pkgver-py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
-noextract=("$_wheel")
+depends=(python-wheel python-pyelftools)
+_pyarch=py3
+_wheel="$pkgname-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${pkgname::1}/$pkgname/$_wheel")
sha256sums=('daa496bb307012502dd70ba6116b14e28849a30e93b290fb403e83b4926c8918')
+noextract=("$_wheel")
package() {
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}