summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58124da783ac..4fd479214428 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Auroot <2763833502@qq.com>
pkgname='auin'
pkgver=v4.0.5
-pkgrel=1
+pkgrel=2
arch=('any')
url="https://www.auroot.cn/"
pkgdesc="Archlinux system installation script."
license=('GPL3')
-_mirror="https://www.auroot.cn"
-source=("$_mirror/shell/$pkgname-$pkgver.tar.gz")
-md5sums=('42f6f1a5ebb8d9fad4fc2f97232a4843')
+_mirror="https://gitee.com/auroot/Arch_install/attach_files"
+source=("$_mirror/552104/download/$pkgname-$pkgver.tar.gz")
+md5sums=('7a13530a621e45f9b758fb00147b91ef')
build(){
msg "Extracting DPKG package ..."
mkdir -p "${srcdir}/"
- tar zxf $pkgname-$pkgver.tar.gz -C "${srcdir}/"
}
package() {
mkdir -p "${HOME}/.auin"
install -d "${pkgdir}/usr/bin/"
- cp -a ${srcdir}/auin/$pkgname-$pkgver/* "${HOME}/.auin/"
- install -m775 "${srcdir}/$pkgname-$pkgver/auin.sh" "${HOME}/.auin/"
+ rm ${srcdir}/$pkgname-$pkgver.tar.gz
+ cp -a ${srcdir}/* "${HOME}/.auin/"
+ install -m775 "${srcdir}/auin" "${HOME}/.auin/"
msg "Create a link to the executable file ...."
- ln -sf "${HOME}/.auin/auin.sh" "${pkgdir}/usr/bin/auin"
+ ln -sf "${HOME}/.auin/auin" "${pkgdir}/usr/bin/auin"
}