summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4a34a6f4065
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Alexandria Pettit <alxpettit@gmail.com>
+_pkgname=aur-audit
+pkgname="${_pkgname}-git"
+pkgver=r2.e7e053c
+pkgrel=1
+pkgdesc="Audit AUR packages more easily"
+arch=('any')
+url="https://github.com/alxpettit/${_pkgname}"
+license=('GPL3')
+makedepends=('git')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "${pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}