summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 470c8e165dd6..56f7a812464e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=auracle-git
_pkgname=auracle
pkgver=r255.5435855
-pkgrel=1
+pkgrel=2
pkgdesc='A flexible client for the AUR'
arch=('x86_64' 'i686')
url="https://github.com/falconindy/auracle.git"
@@ -23,10 +23,15 @@ pkgver() {
build() {
cd "$_pkgname"
- meson build --wipe \
- --prefix=/usr \
- --buildtype=plain \
+ local meson_args=(
+ --prefix=/usr
+ --buildtype=plain
--default-library=static
+ )
+
+ [[ -d build ]] && meson_args+=(--wipe)
+
+ meson build "${meson_args[@]}"
ninja -C build
}