summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5432ed3ab4ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=aurrpkgs-git
+pkgver=r8.86048fb
+pkgrel=1
+pkgdesc="Manage AUR R packages "
+arch=(any)
+license=('GPL3')
+url="https://github.com/dvdesolve/aurrpkgs"
+depends=('python>=3.2.0')
+provides=('aurrpkgs')
+conflicts=('aurrpkgs')
+source=("$pkgname::git+https://github.com/dvdesolve/aurrpkgs.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+
+ install -Dm755 aurrpkgs.py "${pkgdir}/usr/bin/aurrpkgs"
+}