summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a9e5fce325f..4e1c0b18594e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=aurutils
-pkgver=0.8.5
-pkgrel=2
+pkgver=0.9.1
+pkgrel=1
pkgdesc='helper tools for the arch user repository'
arch=('any')
url=https://github.com/AladW/aurutils
license=('ISC')
source=("$url/archive/$pkgver.tar.gz")
-md5sums=('65eca72eeefe1ee2db1c56ff844273ea')
-depends=('pacman>=5.0' 'git' 'jshon' 'expac' 'aria2'
+sha256sums=('9bde7b37c18c12159d048c722e0df602e79faa2fdc75a069bc0be7eadf898201')
+depends=('pacman>=5' 'expac>=7' 'aria2>=1.23' 'git' 'jshon'
'repose' 'pacutils' 'datamash')
checkdepends=('shellcheck')
makedepends=('git')
@@ -16,16 +16,10 @@ optdepends=('devtools: build in an nspawn container'
check() {
cd "$pkgname-$pkgver"
- LANG=C shellcheck -e 2016 -x bin/*
+ make check
}
package() {
cd "$pkgname-$pkgver"
- install -d "$pkgdir"/usr/{bin,share{/zsh/site-functions,/man/man1,{/licenses,/doc}/aurutils}}
-
- install -m755 bin/* "$pkgdir"/usr/bin/
- install -m644 completions/* "$pkgdir"/usr/share/zsh/site-functions/
- install -m644 doc/* "$pkgdir"/usr/share/man/man1/
- install -m644 LICENSE "$pkgdir"/usr/share/licenses/aurutils/
- install -m644 CREDITS README "$pkgdir"/usr/share/doc/aurutils/
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
}