summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bde505c89244
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jaden Peterson <jadenpeterson150@gmail.com>
+
+pkgname=aurvote-utils-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A set of utilities for managing AUR votes'
+arch=('any')
+url=https://github.com/jadenPete/aurvote-utils
+provides=('aurvote-utils')
+conflicts=('aurvote-utils' 'aurvote')
+license=('MIT')
+depends=('python' 'python-beautifulsoup4' 'python-requests')
+makedepends=('git')
+source=("git+https://github.com/jadenPete/aurvote-utils.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd aurvote-utils
+ git describe --tags | tail -c +2 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd aurvote-utils
+ install -D aurvote "${pkgdir}/usr/bin/aurvote"
+ install aurvote-auto "${pkgdir}/usr/bin/aurvote-auto"
+}