summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d86b388a4fc5..08106862f6c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: BrainDamage
pkgname="authsae-git"
pkgrel=1
-pkgver="20150123.8531ab1"
+pkgver=20160420.a1ebd8c
pkgdesc="Authsae provides secure password-based authentication for 802.11s mesh networking."
arch=('x86' 'x86_64')
url="https://github.com/cozybit/authsae"
license=("BSD")
-depends=("openssl")
-makedepends=("git")
+depends=("openssl" "libconfig")
+makedepends=("git" "cmake")
provides=("authsae")
conflicts=("authsae")
optdepends=()
@@ -22,7 +22,7 @@ pkgver() {
build() {
cd "$srcdir/authsae"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .
#FIXME: the cmake script does something very wrong and attempts to install the config file in prefix+/etc, submit patch to upstream to allow to change that
sed -i 's/\/usr\/etc/\/etc/' cmake_install.cmake
make