summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c21753118308..32a90e23f240 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='Directory based enviroments'
arch=('any')
url='https://github.com/kennethreitz/autoenv'
license=('custom')
-source=('git+https://github.com/kennethreitz/autoenv.git')
+source=("$pkgname"::'git+https://github.com/kennethreitz/autoenv.git')
sha256sums=('SKIP')
depends=('bash')
optdepends=('zsh: if you prefer zsh over bash')
@@ -16,9 +16,9 @@ makedepends=('git')
conflicts=('autoenv')
pkgver() {
- cd autoenv
+ cd "$pkgname"
set -o pipefail
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ # git describe --tags --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
# If there is a setup.py then pull the version tag from the file
if [ -f "setup.py" ]; then