summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e74d50567ff8..8754d10266f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,14 +18,13 @@ conflicts=('autoenv')
pkgver() {
cd "$pkgname"
set -o pipefail
- # git describe --tags --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ git describe --tags --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
# If there is a setup.py then pull the version tag from the file
if [ -f "setup.py" ]; then
- printf "%s." "$(grep -R "version=" setup.py | awk -F\' '{print $2}')"
+ printf "%s.r%s.g%s" "$(grep -R "version=" setup.py | awk -F\' '{print $2}')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
fi
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {