summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5eb56b9346e9..5fd1156e6a00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('autokey-common' 'autokey-gtk' 'autokey-qt')
pkgbase=autokey
pkgver=0.96.0
-pkgrel=2
+pkgrel=3
pkgdesc="A desktop automation utility for Linux and X11"
arch=('any')
url="https://github.com/autokey/autokey"
@@ -13,6 +13,13 @@ makedepends=('python-build' 'python-installer' 'python-pyqt5' 'python-setuptools
source=("$pkgbase-$pkgver.tar.gz::https://github.com/autokey/autokey/archive/v$pkgver.tar.gz")
sha256sums=('40341fc4cd9703a34264e9191b5938fc7ed5a6f357992d91e492975d89933acd')
+prepare() {
+ cd "$pkgbase-$pkgver"
+
+ # bump Notify to 0.8
+ sed -i "s/'Notify', '0.7'/'Notify', '0.8'/g" lib/autokey/gtkui/notifier.py
+}
+
build() {
cd "$pkgbase-$pkgver"
python -m build --wheel --no-isolation