summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb3f1a44c6df..d4bee4ff530c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Johannes Wienke <languitar@semipol.de>
pkgname=autosuspend
-pkgver=2.0.3
+pkgver=7.0.0
pkgrel=1
pkgdesc="A daemon to suspend and wake up a system based on configurable checks"
arch=(any)
url="https://github.com/languitar/autosuspend"
license=('GPL2')
-depends=('python' 'python-psutil')
+depends=('python' 'python-psutil' 'python-portalocker')
optdepends=('python-dbus: logind session discovery'
'python-mpd2: MPD playing status check'
'python-requests: network-based checks'
@@ -17,34 +17,45 @@ optdepends=('python-dbus: logind session discovery'
'python-dateutil: iCalendar checks'
'python-tzlocal: iCalendar checks'
'python-requests-file: file:// URL support'
+ 'python-jsonpath-ng: JSONPath checks'
'iputils: ping check'
'xprintidle: X server idle time check')
-makedepends=('python-setuptools' 'python-pytest-runner' 'python-sphinx' 'python-sphinx_rtd_theme' 'python-sphinx-issues')
-source=("https://github.com/languitar/autosuspend/archive/v${pkgver}.tar.gz")
-sha256sums=('80537bf841c9ac80078b2f817039dda9f485c8ae8563f4bb187b7b8ad34d7ae1')
+makedepends=('python-setuptools'
+ 'python-pytest-runner'
+ 'python-recommonmark'
+ 'python-sphinx'
+ 'python-sphinx-furo'
+ 'python-sphinx-issues'
+ 'python-sphinxcontrib-plantuml'
+ 'python-sphinx-autodoc-typehints')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/languitar/autosuspend/archive/v${pkgver}.tar.gz")
+sha256sums=('3f09e61a7679bf1769b2587cbb597622885284c7e6be1821d02a304816a936fe')
+install="${pkgname}.install"
backup=('etc/autosuspend.conf'
'etc/autosuspend-logging.conf')
build() {
cd "$pkgname-${pkgver}"
- python3 setup.py build_sphinx -a -b html
- python3 setup.py build_sphinx -a -b man
+ python -m build --wheel --no-isolation
+ export PYTHONPATH=$(pwd)/src
+ sphinx-build -a -b html doc/source/ doc/build/html
+ sphinx-build -a -b man doc/source/ doc/build/man
}
package() {
cd "$pkgname-${pkgver}"
- python3 setup.py install --root="$pkgdir/" --install-data=/usr
+ python -m installer --destdir="$pkgdir" dist/*.whl
# setuptools install_data is a nightmare, and cannot be made to respect the
# filesystem hierarchy. Do things manually instead.
mv "$pkgdir/usr/etc" "$pkgdir"
- # man pages
+ # # man pages
mkdir -p "${pkgdir}/usr/share/man/man1"
cp doc/build/man/autosuspend.1 "${pkgdir}/usr/share/man/man1"
mkdir -p "${pkgdir}/usr/share/man/man5"
cp doc/build/man/autosuspend.conf.5 "${pkgdir}/usr/share/man/man5"
- # HTML help
+ # # HTML help
mkdir -p "${pkgdir}/usr/share/doc"
cp -R doc/build/html "${pkgdir}/usr/share/doc/${pkgname}"
}