summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c7f076e8157..750e3b720803 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
# Maintainer: Johannes Wienke <languitar@semipol.de>
pkgname=autosuspend
-pkgver=1.1.0
+pkgver=2.0.1
pkgrel=1
-pkgdesc="A daemon to suspend your server in case of inactivity"
+pkgdesc="A daemon to suspend and wake up a system based on configurable checks"
arch=(any)
url="https://github.com/languitar/autosuspend"
license=('GPL2')
depends=('python' 'python-psutil')
optdepends=('python-dbus: logind session discovery'
'python-mpd2: MPD playing status check'
- 'python-requests: Kodi playing status and XPath check'
+ 'python-requests: network-based checks'
'python-lxml: XPath check'
+ 'python-dbus: logind-based checks'
+ 'python-icalendar: iCalendar checks'
+ 'python-dateutil: iCalendar checks'
+ 'python-tzlocal: iCalendar checks'
+ 'python-requests-file: file:// URL support'
+ 'iputils: ping check'
'xprintidle: X server idle time check')
-makedepends=('python-setuptools' 'python-pytest-runner' 'python-sphinx' 'python-sphinx_rtd_theme')
+makedepends=('python-setuptools' 'python-pytest-runner' 'python-sphinx' 'python-sphinx_rtd_theme' 'python-sphinx-issues')
source=("https://github.com/languitar/autosuspend/archive/v${pkgver}.tar.gz")
-sha256sums=('2d6dc969e020e69eb372df99ad24d4c15dda72b5d5717c368727f5cc3cab211b')
+sha256sums=('5ca2a7b9ad06b8d6c714127239c2f1dc46c1b50d3977a89e4d55c42d4e03ee23')
install="${pkgname}.install"
backup=('etc/autosuspend.conf'
'etc/autosuspend-logging.conf')