summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d384cfaa0505..64584389c33f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=avahi-git
-pkgver=0.6.32.rc.r7.g916f65b
+pkgver=v0.7.r59.g4a5454f
pkgrel=1
pkgdesc='Multicast DNS-SD / Zeroconf Suite git master'
url='http://www.avahi.org/'
license=(LGPL)
arch=(i686 x86_64)
depends=(expat libdaemon glib2 libcap gdbm dbus)
-makedepends=(git qt4 pygtk mono intltool python2-dbus gtk-sharp-2 gobject-introspection gtk3
- xmltoman python-dbus)
+makedepends=(git qt5-base pygtk mono intltool expat dbus gtk-sharp-2 gobject-introspection gtk3 xmltoman python-dbus nss-mdns python-gobject)
optdepends=('gtk3: avahi-discover-standalone, bshell, bssh, bvnc'
'gtk2: gtk2 bindings'
- 'qt4: qt4 bindings'
+ 'pygtk'
+ 'qt5-base: qt bindings'
'pygtk: avahi-bookmarks, avahi-discover'
'python2-twisted: avahi-bookmarks'
'mono: mono bindings'
@@ -40,42 +40,42 @@ prepare() {
build() {
cd avahi
- export MOC_QT4=/usr/bin/moc-qt4 PYTHON=/usr/bin/python2
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--sbindir=/usr/bin \
+ with_dbus_sys=/usr/share/dbus-1/system.d \
--disable-monodoc \
- --disable-qt3 \
+ --disable-qt4 \
--enable-compat-libdns_sd \
- --enable-compat-howl \
--with-distro=archlinux \
--with-avahi-priv-access-group=network \
--with-autoipd-user=avahi \
--with-autoipd-group=avahi \
--with-systemdsystemunitdir=/usr/lib/systemd/system
- cp -a avahi-python/avahi avahi-python/avahi3
-
make
- make -C avahi-python/avahi3 PYTHON=/usr/bin/python3
}
package() {
cd avahi
make DESTDIR="$pkgdir" install
- make DESTDIR="$pkgdir" -C avahi-python/avahi3 install \
- PYTHON=/usr/bin/python3 pythondir=/usr/lib/python3.5/site-packages
- # howl compat
- ln -s avahi-compat-howl "$pkgdir/usr/include/howl"
- ln -s avahi-compat-howl.pc "$pkgdir/usr/lib/pkgconfig/howl.pc"
+ rmdir "$pkgdir/run"
+
+ # this isn't ported
+ sed -i '1s|python3|python2|' "$pkgdir/usr/bin/avahi-bookmarks"
# mdnsresponder compat
ln -s avahi-compat-libdns_sd/dns_sd.h "$pkgdir/usr/include/dns_sd.h"
- # see FS#42638
- ln -s avahi-daemon.service "$pkgdir/usr/lib/systemd/system/dbus-org.freedesktop.Avahi.service"
+ # move example services https://bugs.archlinux.org/task/47822
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir"/etc/avahi/services/{,sftp-}ssh.service \
+ "$pkgdir/usr/share/doc/$pkgname/"
+
+ echo 'u avahi - "Avahi mDNS/DNS-SD daemon"' |
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
}