summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b7d77638b6c..c5106faea67e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,42 @@
_plug=rawsource26
pkgname=avisynth-plugin-${_plug}-git
-pkgver=1.3.1.0.gae700df
+pkgver=1.3.2.0.g700e7e2
pkgrel=1
pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/Asd-g/RawSource_2.6x'
license=('custom')
-depends=('avisynthplus')
+depends=('libavisynth.so')
makedepends=('git'
'cmake'
+ 'avisynthplus'
)
provides=("avisynth-plugin-${_plug}")
conflicts=("avisynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/Asd-g/RawSource_2.6x.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-prepare() {
- mkdir -p "${_plug}/build"
-}
-
build() {
- cd "${_plug}/build"
+ cd "${_plug}"
+
+ CXXFLAGS+=" $(pkg-config --cflags avisynth)"
- CXXFLAGS+=" $(pkg-config --cflags avisynth)" cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -S . -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
package(){
- make -C "${_plug}/build" DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install "${_plug}/build"
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
}