summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7f650d421bd..9982328f630b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
pkgname=avml
-pkgver=0.3.0
+pkgver=0.4.1
pkgrel=1
pkgdesc='A portable volatile memory acquisition tool for Linux'
arch=('x86_64')
@@ -8,7 +8,12 @@ url='https://github.com/microsoft/avml'
license=('MIT')
makedepends=('musl' 'rust-musl')
source=("https://github.com/microsoft/avml/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('e9ae6f99c5278b7acf732e85753e9befcd76937e2343cd8785e096ed03ffe8d2')
+sha256sums=('f13a5c59e978b688623e67c7497dedc165a2955216dd947eacaf23d801c72aea')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-musl"
+}
build() {
cd "$pkgname-$pkgver"