summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 38 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e48e05d6e71..1897c886cd0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,24 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
-pkgname=avxsynth-git
+pkgbase=avxsynth-git
+pkgname=('avxsynth-git' 'avxedit-git')
pkgver=20150407.80dcb7e
pkgrel=1
pkgdesc="Linux Port of AviSynth. (Git version)"
arch=('i686' 'x86_64')
url="http://www.avxsynth.org"
license=('GPL2')
-depends=('qt4' 'mplayer' 'log4cpp' 'pango' 'ffms2')
-makedepends=('git' 'yasm' 'subversion' 'python2')
-provides=('avxsynth')
-conflicts=('avxsynth')
+depends=()
+makedepends=('git'
+ 'yasm'
+ 'subversion'
+ 'python2'
+ 'qt4'
+ 'mplayer'
+ 'log4cpp'
+ 'pango'
+ 'ffms2'
+ )
source=('git+https://github.com/avxsynth/avxsynth.git')
sha1sums=('SKIP')
@@ -26,10 +34,33 @@ prepare() {
build() {
cd avxsynth
- ./configure --prefix=/usr --enable-silent-rules
+ ./configure \
+ --prefix=/usr \
+ --enable-silent-rules
make
}
-package() {
+package_avxsynth-git() {
+pkgdesc="Linux Port of AviSynth. (Git version)"
+ depends=('ffms2'
+ 'ffmpeg'
+ 'log4cpp'
+ 'pango'
+ )
+ provides=('avxsynth')
+ conflicts=('avxsynth')
+
make -C avxsynth DESTDIR="${pkgdir}" install
+ make -C avxsynth/apps/AVXEdit DESTDIR="${pkgdir}" uninstall
}
+
+package_avxedit-git() {
+ pkgdesc="Simple Qt4 frontend for create/edit/test AvxSynth scripts. (Git version)"
+ depends=('qt4'
+ 'avxsynth-git'
+ )
+ provides=('avxedit')
+ conflicts=('avxedit')
+
+ make -C avxsynth/apps/AVXEdit DESTDIR="${pkgdir}" install
+} \ No newline at end of file