summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bacf28d27d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Payson Wallach <payson@paysonwallach.com>
+
+pkgname=aw-watcher-window
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Log what you do on your computer. Simple, extensible, no third parties."
+arch=('i686' 'x86_64')
+url="https://github.com/ActivityWatch/activitywatch"
+license=('MPL2')
+depends=('python>=3.5.1')
+makedepends=('python>=3.5.1' 'python-setuptools')
+source=("git+https://github.com/ActivityWatch/aw-watcher-window.git#commit=0c14d77")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+}