summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ed102b015ab..4808cfa6f5dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
pkgname=aws-iam-authenticator-bin
-pkgver=1.10.3
+pkgver=0.3.0
pkgrel=1
pkgdesc="A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster"
arch=('x86_64')
url="https://github.com/kubernetes-sigs/aws-iam-authenticator"
license=('Apache')
provides=('aws-iam-authenticator')
-source=("https://amazon-eks.s3-us-west-2.amazonaws.com/${pkgver}/2018-07-26/bin/linux/amd64/aws-iam-authenticator")
-noextract=("aws-iam-authenticator")
-sha256sums=("246f6d13b051bbfb12962edca074c8f67436930e84b2bec3a45a5d9242dc6f0c")
+source=("https://github.com/kubernetes-sigs/aws-iam-authenticator/releases/download/v${pkgver}/heptio-authenticator-aws_${pkgver}_linux_amd64")
+noextract=("heptio-authenticator-aws_${pkgver}_linux_amd64")
+sha256sums=("4b8ecce88f4749338e361baf1fba9f8970efed0ac3f58cc40b4979bc0d86eb7b")
package() {
- install -Dm 755 "${srcdir}/aws-iam-authenticator" "${pkgdir}/usr/bin/aws-iam-authenticator"
+ install -Dm 755 "${srcdir}/heptio-authenticator-aws_${pkgver}_linux_amd64" "${pkgdir}/usr/bin/aws-iam-authenticator"
}