summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 634447af307e..5ffbb95383d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor: Aaron Miller <aaronm@cldtk.com>
pkgname=aws-sam-cli
-pkgver=1.114.0
+_name=$pkgname
+pkgver=1.117.0
pkgrel=1
pkgdesc='CLI tool to build, test, debug, and deploy Serverless applications using AWS SAM'
arch=('any')
@@ -11,19 +12,23 @@ license=('Apache')
depends=('docker' 'python-aws-lambda-builders' 'python-aws-sam-translator' 'python-boto3' 'python-cfn-lint'
'python-chevron' 'python-click' 'python-cookiecutter' 'python-dateparser' 'python-docker' 'python-flask'
'python-jmespath' 'python-pyopenssl' 'python-requests' 'python-rich' 'python-ruamel-yaml' 'python-tomlkit'
- 'python-typing-extensions' 'python-watchdog' 'python-yaml' 'python-mypy-boto3-apigateway'
+ 'python-typing_extensions' 'python-watchdog' 'python-yaml' 'python-mypy-boto3-apigateway'
'python-mypy-boto3-cloudformation' 'python-mypy-boto3-ecr' 'python-mypy-boto3-iam' 'python-mypy-boto3-lambda'
'python-mypy-boto3-s3' 'python-mypy-boto3-schemas' 'python-mypy-boto3-secretsmanager'
'python-mypy-boto3-signer' 'python-mypy-boto3-stepfunctions' 'python-mypy-boto3-sts' 'python-mypy-boto3-xray'
'python-mypy-boto3-kinesis' 'python-mypy-boto3-sqs'
)
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('fa60c16a3ab56d6abc1506f63644a4aff19981fab17793355b32537612394fe1')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/${_name//-/_}-$pkgver.tar.gz")
+sha256sums=('f54542da4715e815d77cacf077f9f3b2570956f9052838367e18d151b8fe82af')
-package() {
- cd "$pkgname-$pkgver"
+build() {
+ cd "${_name//-/_}-$pkgver"
+ python -m build --wheel --no-isolation
+}
- /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1
+package() {
+ cd "${_name//-/_}-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}