summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17a694e39127..0c3e78ece257 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: kotontrion <kotontrion@tutanota.de>
pkgname=aylurs-gtk-shell-git
_pkgname=ags
-pkgver=v1.3.0.r9.g5158079
+pkgver=v1.4.0.r3.gc7b2607
pkgrel=1
pkgdesc="Aylurs's Gtk Shell (AGS), An eww inspired gtk widget system."
arch=('x86_64')
url="https://github.com/Aylur/ags"
license=('GPL3')
makedepends=('git' 'meson' 'npm')
-depends=('glib2' 'libpulse' 'glibc' 'typescript' 'gjs' 'gtk3' 'gtk-layer-shell' 'gobject-introspection' 'gnome-bluetooth-3.0' 'upower' 'networkmanager' 'libdbusmenu-gtk3')
+depends=('glib2' 'libpulse' 'glibc' 'typescript' 'gjs' 'gtk3' 'gtk-layer-shell' 'gobject-introspection')
+optdepends=('gnome-bluetooth-3.0: required for bluetooth service'
+ 'upower: required for battery service'
+ 'networkmanager: required for network service'
+ 'libdbusmenu-gtk3: required for systemtray service')
conflicts=('aylurs-gtk-shell')
source=("git+${url}"
- "git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions#branch=nightly"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control")
sha256sums=('SKIP'
- 'SKIP'
'SKIP')
pkgver(){
@@ -25,7 +27,6 @@ pkgver(){
prepare() {
cd $srcdir/$_pkgname
git submodule init
- git config submodule.gi-types.url "$srcdir/gi-typescript-definitions"
git config submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git -c protocol.file.allow=always submodule update
}