summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 11 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09c724018719..ef8dbf926ca1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,26 @@
#
pkgname=azpainter
-pkgver=2.1.7
+pkgver=3.0.1
pkgrel=1
-pkgdesc="Painting software"
+pkgdesc='Painting software'
arch=('i686' 'x86_64')
-url="http://azsky2.html.xdomain.jp/soft/azpainter.html"
+url='http://azsky2.html.xdomain.jp/soft/azpainter.html'
license=('GPL3')
-depends=('hicolor-icon-theme' 'fontconfig' 'libjpeg-turbo' 'libxi')
-makedepends=('libxfixes')
+depends=('hicolor-icon-theme' 'fontconfig' 'libjpeg-turbo' 'libxi' 'libxcursor' 'libwebp')
options=('!makeflags')
-source=("http://azsky2.html.xdomain.jp/arc/azpainter-2.1.7.tar.xz"
- "${pkgname}-${pkgver}-translations.patch")
-sha256sums=('62e0ce810ada061864c728dbb7dd8c3eb7398566657d758442e9fd33b3db5cb4'
- 'b0ed4040480a8a4c5fea5b754b8f11c7925371ececa7dcee6d5416fb85a829fd')
-
-
-prepare() {
- cd ${pkgname}-${pkgver}
- # fixing translations
-
- patch -Np1 -i ../"${pkgname}-${pkgver}-translations.patch"
-
- cd translation
- make
- ./mtrconv en en.mtr
- ./mtrconv ru ru.mtr
- ./mtrconv uk uk.mtr
-}
+source=(http://azsky2.html.xdomain.jp/arc/azpainter-3.0.1.tar.xz)
+sha256sums=('990658c5ac54b08c14796d593a870f8d26c27d13b8a8c7224a4e0c7ff0182a37')
build() {
- cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr
- # make -j1
- make
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
}
package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
- cp -f translation/*.mtr ${pkgdir}/usr/share/azpainter/tr/
+ cd ${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
}