summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4707e12f08c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Lukas Grossar <lukas.grossar@gmail.com>
+
+pkgname=azwi-bin
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="CLI that helps manage Entra ID Workload Identity"
+arch=('x86_64')
+url="https://github.com/Azure/azure-workload-identity"
+license=('MIT')
+source=("https://github.com/Azure/azure-workload-identity/releases/download/v${pkgver}/azwi-v${pkgver}-linux-amd64.tar.gz")
+sha256sums=('d2ef0f27609b7157595fe62b13c03381a481f833c1e1b6290df560454890d337')
+
+package() {
+ install -Dm 755 "$srcdir/azwi" -t "$pkgdir/usr/bin"
+
+ "$pkgdir/usr/bin/azwi" completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/azwi"
+ "$pkgdir/usr/bin/azwi" completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_azwi"
+ "$pkgdir/usr/bin/azwi" completion fish | install -Dm644 /dev/stdin "$pkgdir/usr/share/fish/vendor_completions.d/azwi.fish"
+}