summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b9a4abe86db..c4fbe0f6d278 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=backblaze-b2
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Backblaze B2 Command Line Client"
url="https://www.backblaze.com/b2/cloud-storage.html"
depends=('python')
@@ -15,6 +15,10 @@ source=("https://docs.backblaze.com/public/b2_src_code_bundles/b2")
sha512sums=('29384d8d271c0b595ca922819683de2ae235dfd6725ce979f8d50efb0727063df516247e681e2445de84f1f16e29e67f4c447f714cf1a4461d52da297e16dbc5')
package() {
+ # Hardcode python2, converting is frivilous
+ # I started to convert it but after 2to3, decode() I gave up
+ sed -ie 's:^#\! /usr/bin/python$:#! /usr/bin/env python2:' b2
+
# Installed to backblaze-b2 because the Boost pkg installs /usr/bin/b2
install -D ${srcdir}/b2 ${pkgdir}/usr/bin/backblaze-b2
}