summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f6d3837ea3b..6c1835e3ef81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=backblaze-b2
_pkgname=b2
-pkgver=3.6.0
+pkgver=3.7.1
pkgrel=1
pkgdesc='Backblaze B2 Command Line Client'
url='https://github.com/Backblaze/B2_Command_Line_Tool'
@@ -10,7 +10,7 @@ depends=('python'
'python-arrow>=1.0.2'
'python-b2sdk>=1.18.0'
'python-docutils>=0.19'
- 'python-class-registry=3.0.5'
+ 'python-class-registry>=4.0.5'
'python-rst2ansi=0.1.5'
'python-tabulate>=0.8.10'
)
@@ -24,7 +24,7 @@ license=('MIT')
arch=('any')
source=("https://github.com/Backblaze/B2_Command_Line_Tool/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('a879e751348b635ca772a2231be20c2e835abaf830534e2ab2f1fb75967c0252')
+sha256sums=('68b10511447576c3286159f5fe66ee180dddb4547dcb4a423fa964454720019f')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
@@ -41,7 +41,10 @@ package() {
cd ${srcdir}/${_pkgname}-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # uu-coreutils messes up the directory permissions (644, expect 755)
+ #install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install LICENSE "$pkgdir/usr/share/licenses/$pkgname"
# https://wiki.archlinux.org/index.php/Python_package_guidelines
local site_packages=$(python -c 'import site; print(site.getsitepackages()[0])')