summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41df2d8d2236..11a16d0d052c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,21 @@ _pkgname=backblaze-b2
_reponame="B2_Command_Line_Tool"
pkgname="${_pkgname}-git"
-pkgver=r987.c1e4a38
+pkgver=r1123.15a60ad
pkgrel=1
pkgdesc="Backblaze B2 Command Line Client."
arch=('any')
url="https://www.backblaze.com/b2/cloud-storage.html"
license=('MIT')
-depends=('python2' 'python2-arrow' 'python2-futures' 'python2-logfury' 'python2-portalocker' 'python2-requests' 'python2-tqdm')
-makedepends=('git' 'python2-setuptools')
+depends=('python2'
+ 'python2-arrow'
+ 'python2-futures'
+ 'python2-logfury'
+ 'python2-requests'
+ 'python2-six'
+ 'python2-tqdm')
+makedepends=('git'
+ 'python2-setuptools')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git://github.com/Backblaze/$_reponame.git")
@@ -32,6 +39,8 @@ package() {
cd "$srcdir/$_reponame"
python2 setup.py install --root="$pkgdir" --optimize=1
+ rm -rf "$pkgdir"/usr/lib/python*/site-packages/test
+
install -Dm0644 contrib/bash_completion/b2 \
"$pkgdir/etc/bash_completion.d/b2"
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"