summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 230f57c80f2a..49fbab26d759 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=backend.ai-desktop
pkgname="${_pkgname//./-}-bin"
_appname="Backend.AI Desktop"
-pkgver=23.09.2
+pkgver=23.09.3
pkgrel=1
pkgdesc="Backend.AI Web UI provides a convenient environment for users, while allowing various commands to be executed without CLI. It also provides some visual features that are not provided by the CLI, such as dashboards and statistics."
arch=("aarch64" "x86_64")
@@ -11,14 +11,21 @@ _githuburl="https://github.com/lablup/backend.ai-webui"
license=('LGPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}" "${_pkgname%-desktop}" "${_pkgname}")
-depends=('bash' 'electron26' 'hicolor-icon-theme')
-makedepends=('asar' 'gendesk')
+depends=(
+ 'bash'
+ 'electron26'
+ 'hicolor-icon-theme'
+)
+makedepends=(
+ 'asar'
+ 'gendesk'
+)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-arm64.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
-sha256sums=('bcda93b2c524c907a016454bbcbffdc35bee6b5509145691f634e601fc00abae')
-sha256sums_aarch64=('5b31c69aebd24a7ed1fa13f99d64d17041cbd69f831a62e328d84ec550e081e0')
-sha256sums_x86_64=('f371d789f6ea217819a51e97a0a855caccf236f4a6ed6b60d64fdd32f1dd7881')
+sha256sums=('27e8e3578355522309a16c4812b43e11f4632196060696b2705a8fca9a65c3f3')
+sha256sums_aarch64=('6fefe8314da172bc1d6b2a7207cbc5e717dec9868185ee40d3ade49c1b1b4f69')
+sha256sums_x86_64=('ca2f42e27fa9725a04ff694bebd0b86bf5c98bc50a84739560f3032daa619bac')
build() {
gendesk -q -f -n --pkgname="${_pkgname//./-}-bin" --categories "Development" --name "${pkgname%-bin}" --exec "${pkgname%-bin}"
asar e "${srcdir}/${_appname}-linux-"*/resources/app.asar "${srcdir}/app.asar.unpacked"