summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 31 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b77cd57484b8..a4fd705da836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,59 +3,53 @@
pkgname=('backintime' 'backintime-cli')
_pkgname="backintime"
-pkgver=1.1.24
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
arch=('any')
url="https://github.com/bit-team/backintime"
license=('GPL')
makedepends=('python')
#source=("https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
source=("$_pkgname-$pkgver.tar.gz::https://github.com/bit-team/$_pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('74f391217c3fc33cea75abbd758914a003c1ee3bf815f31a75e7dc4c7bf11960')
-
-prepare() {
- cd "$_pkgname-$pkgver"
-
- # patches here
-}
+sha256sums=('79eb77060df2471b0a3baacacab237cc4ee0d712d27e5b98c5398550e89d2115')
build() {
- cd "$_pkgname-$pkgver/common"
- ./configure --python --no-fuse-group
- make
+ cd "$_pkgname-$pkgver/common"
+ ./configure --python --no-fuse-group
+ make
- cd "$srcdir/$_pkgname-$pkgver/qt4"
- ./configure --python
- make
+ cd "$srcdir/$_pkgname-$pkgver/qt"
+ ./configure --python
+ make
}
test() {
- cd "$_pkgname-$pkgver/common"
- make test
+ cd "$_pkgname-$pkgver/common"
+ make test
}
package_backintime-cli() {
- pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."
- depends=('rsync' 'cron' 'openssh' 'python-keyring' 'python-dbus' 'polkit' 'python-sip-pyqt4')
- optdepends=('backintime: QT4 GUI version'
- 'encfs: encrypted filesystem in user-space'
- 'pm-utils: for laptops allows an option to not snapshot on battery'
- 'sshfs: FUSE client based on the ssh file transfer protocol')
-
- cd "$_pkgname-$pkgver/common"
- make DESTDIR="$pkgdir" install
+ pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. CLI version."
+ depends=('cron' 'fuse2' 'openssh' 'python-dbus' 'python-keyring' 'rsync')
+ optdepends=('backintime: QT5 GUI version'
+ 'encfs: encrypted filesystem in user-space'
+ 'pm-utils: for laptops allows an option to not snapshot on battery'
+ 'sshfs: FUSE client based on the ssh file transfer protocol')
+
+ cd "$_pkgname-$pkgver/common"
+ make DESTDIR="$pkgdir" install
}
package_backintime() {
- pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. QT4 GUI version."
- depends=("backintime-cli=$pkgver" 'xorg-xdpyinfo' 'python-pyqt4' 'libnotify'
- 'ttf-font' 'icu' 'polkit')
-
- # note users can optionally install EITHER kompare OR meld but not both!
- optdepends=('kompare: diff/patch frontend'
- 'meld: diff/patch frontend'
- 'python-keyring: store and access passwords safely')
-
- cd "$_pkgname-$pkgver/qt4"
- make DESTDIR="$pkgdir" install
+ pkgdesc="Simple backup system inspired from the Flyback Project and TimeVault. QT5 GUI version."
+ depends=("backintime-cli=$pkgver" 'libnotify' 'polkit' 'python-dbus' 'python-pyqt5' 'xorg-xdpyinfo')
+ # note users can optionally install EITHER kompare OR meld but not both!
+ optdepends=('kompare: diff/patch frontend'
+ 'meld: diff/patch frontend'
+ 'python-keyring: store and access passwords safely')
+
+ cd "$_pkgname-$pkgver/qt"
+ make DESTDIR="$pkgdir" install
}
+
+# vim:set ts=8 sts=2 sw=2 et: