summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 17 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28534e314f50..2bdf040c470f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,37 @@
-# Maintainer: Ariel AxionL <i at axionl dot me>
# Maintainer: Astro Benzene <universebenzene at sina dot com>
+# Maintainer: Ariel AxionL <i at axionl dot me>
# Contributor: lilydjwg <lilydjwg at gmail dot com>
+# Contributor: kearneyBack <191615342 at qq dot com>
+
_pkgname=baidunetdisk
pkgname=baidunetdisk-bin
-pkgver=3.0.1.2
-pkgrel=4
-_mainver=`echo $pkgver | cut -f -3 -d '.'`
-pkgdesc="Baidu Net Disk is a cloud storage client (Linux Version)."
+pkgver=4.17.7
+pkgrel=1
+#_mainver=${pkgver%.*}
+pkgdesc="Baidu Net Disk - a cloud storage client (Linux Version)."
arch=('x86_64')
-depends=('libxss' 'gtk3' 'nss')
+depends=('libnotify' 'libsecret' 'libxss' 'gtk3' 'nss')
provides=("baidunetdisk")
conflicts=("baidunetdisk")
url="https://pan.baidu.com"
license=("custom")
options=('!strip')
-DLAGENTS=("https::/usr/bin/curl -A 'Mozilla' -fLC - --retry 3 --retry-delay 3 -o %o %u")
-
-source=("LICENSE.html::https://pan.baidu.com/disk/duty/index.html"
- "0001-baidunetdisk-bin-deksktop-file.patch"
+source=("0001-baidunetdisk-bin-desktop-file.patch"
"baidunetdisk-wrapper.sh")
-source_x86_64=("${pkgname}-${pkgver}.deb::https://issuecdn.baidupcs.com/issue/netdisk/LinuxGuanjia/${_mainver}/${_pkgname}_linux_${pkgver}.deb")
+#source_x86_64=("${pkgname}-${pkgver}.deb::https://issuecdn.baidupcs.com/issue/netdisk/LinuxGuanjia/${_mainver}/${_pkgname}_linux_${pkgver}.deb")
+source_x86_64=("${pkgname}-${pkgver}.deb::http://wppkg.baidupcs.com/issue/netdisk/Linuxguanjia/${pkgver}/baidunetdisk_${pkgver}_amd64.deb")
-sha256sums=('b878b89f00a523cd6801a06352314b63fd8c315435063386ccce6a27fd0bdf5c'
- 'd72eb6fa07abc0e7c2298fcecbe4a4e6849c63a6a31c39706e0dfea870e85aff'
+sha256sums=('1e0d9616c58d3b772b42d4790625cf2c34ab671f586b8534a2c544c2117bb5d0'
'c0035e038344a154421301b7855c274049ad432a5b06b52efc74831daa73e02e')
-sha256sums_x86_64=('40eb1950af62a8b9b75da8ffb9a74416ae0d3fc886b07f6de7d63673683b1ef3')
+sha256sums_x86_64=('50ec18f05626a13f57ef034630416d481682bc1018539f33397d5c71bc653b3d')
prepare() {
bsdtar -xpf "data.tar.xz"
- # # modify the HOME environment variable for the application's desktop file
- patch -d "usr" -p1 <"0001-baidunetdisk-bin-deksktop-file.patch"
+ patch -d "usr" -p1 <"0001-baidunetdisk-bin-desktop-file.patch"
+ sed -i '/Name/a Name[zh_CN]=百度网盘' usr/share/applications/${_pkgname}.desktop
}
package() {
@@ -40,16 +39,15 @@ package() {
# install application data
mv "usr" "${pkgdir}"
- install -dm755 "${pkgdir}/usr/bin" "${pkgdir}/usr/lib"
+ install -dm755 "${pkgdir}/usr/lib" "${pkgdir}/usr/share/licenses/${_pkgname}"
mv "opt/${_pkgname}" "${pkgdir}/usr/lib/${_pkgname}"
- install -Dm755 "${srcdir}/baidunetdisk-wrapper.sh" "${pkgdir}/usr/bin/baidunetdisk"
+# install -Dm755 "${srcdir}/baidunetdisk-wrapper.sh" "${pkgdir}/usr/bin/baidunetdisk"
# fix promission
chmod 644 "${pkgdir}/usr/lib/${_pkgname}/"*.so
find ${pkgdir} -type d -exec chmod 755 {} \;
# install license
- install -Dm644 "${srcdir}/LICENSE.html" ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.html
ln -s "/usr/lib/${_pkgname}/LICENSE.electron.txt" \
"${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.electron.txt"
ln -s "/usr/lib/${_pkgname}/LICENSES.chromium.html" \