summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d232c9392ae..fc3e07d5db63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=baidunetdisk
pkgname=baidunetdisk-bin
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Baidu Net Disk is a cloud storage client (Linux Version)."
arch=('x86_64')
depends=('libxss' 'gtk3' 'nss')
@@ -15,19 +15,19 @@ options=('!strip')
DLAGENTS=("https::/usr/bin/curl -A 'Mozilla' -fLC - --retry 3 --retry-delay 3 -o %o %u")
source=("LICENSE.html::https://pan.baidu.com/disk/duty/index.html"
- "baidunetdisk-bin.patch")
+ "0001-baidunetdisk-bin-deksktop-file.patch")
source_x86_64=("${pkgname}-${pkgver}.deb::https://issuecdn.baidupcs.com/issue/netdisk/LinuxGuanjia/${_pkgname}_linux_${pkgver}.deb")
sha256sums=('17cb003654df74201befd7daa9c0ad79d4bde67fa00a5db01a3aa3f813a8ea65'
- '1b0652455f7897d450c8aade088c83eeff7f12c2bca265b822326d75125bfb5f')
+ '4ac5e68e4b029fa292b7272343a0f16480c0e49fd1ab6e750939a342578fd2dd')
sha256sums_x86_64=('6b7993aa75e195b00ba21aa64a743434716eba03a9c7916bde4ef81342c38e3a')
prepare() {
bsdtar -xpf "data.tar.xz"
- # modify the path of executable programs
- patch -d "usr" -p1 <"${pkgname}.patch"
+ # # modify the HOME environment variable for the application's desktop file
+ patch -d "usr" -p1 <"0001-baidunetdisk-bin-deksktop-file.patch"
}
package() {
@@ -49,5 +49,4 @@ package() {
"${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.electron.txt"
ln -s "/usr/lib/${_pkgname}/LICENSES.chromium.html" \
"${pkgdir}/usr/share/licenses/${_pkgname}/LICENSES.chromium.html"
-
}