summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23adbaa99000
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gnarflord <aur@gnarf.link>
+pkgname=bakelite
+pkgver=r70.9e70abd
+pkgrel=1
+pkgdesc="Incremental backup with strong cryptographic confidentiality baked into the data model"
+arch=('x86_64')
+url="https://github.com/richfelker/bakelite"
+license=('GPL2')
+# Stuck at commit 9e70abd, as package no longer compiles as of 2021-02-04
+# See https://github.com/richfelker/bakelite/issues/2
+source=("git+https://github.com/richfelker/bakelite.git#commit=9e70abd")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$pkgname"
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ install -D bakelite "$pkgdir/usr/bin/bakelite"
+}