aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e272b82a08d..ae05cf27bd4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander Jacocks <alexander@redhat.com>
pkgname="bambustudio"
-pkgver=01.04.01.52
+pkgver=01.04.02.13
pkgrel=1
pkgdesc="PC Software for BambuLab's 3D printers"
arch=('x86_64')
@@ -13,12 +13,14 @@ provides=("BambuStudio")
conflicts=("BambuStudio")
source=(
"https://github.com/bambulab/BambuStudio/archive/refs/tags/v${pkgver}.tar.gz"
+ 'https://raw.githubusercontent.com/bambulab/BambuStudio/master/deps/Boost/0001-Boost-fix.patch'
'BambuStudio.cpp.patch'
'TreeSupport.cpp.patch'
'CMakeLists.txt.patch'
'bambu-studio.sh'
)
-sha512sums=('a03dbb7d2dd7b3db7ab00934224dc54da754f3cf1bd4ab0b3799f1b2549426b2bc719a0fe9407093cd9b82b085c69f1ca6c999cd7d30ad699bf3440351aa4b0d'
+sha512sums=('cce63012a8f6b0f9159d314578656696f188303d4ca49ba1d02b4c9984a3326a392d45b9fe8ad56893017326c9d5381560e340b51f16422f7d7b4b993e23d48b'
+ 'fd0c5df8bd82ad8fb96204921a407a4497406bc0d0b13ab11d241d28b6b924baf1d9557974506a8135f6c58ba0b183c6828a63b8b625edc1654484b3630af775'
'419e7ffb8044531a1c78cd191a96c11f719b439afce674f7e31d1d2e0dc57ecc03cea27ab4ad5ee6522606630fd59ac1745b9a1b787db14893561a4495806117'
'674fc00a73b2e5997e5f3dcf74299a2ab5dfac5114247f8b6b0c87bf14f289413ec668a39063ef10a557cc2c45ca08e52a7b1714a1f9f69763edf3a7faa1d01c'
'04d46a8b3ffe459ff19e94a2545f1e7b2cca336d3a3688b7aefbafbfe341301009cf61b59c1901629bbc9919e0a5e0462fb3346d5b72d3264b03e9175fa54c5a'
@@ -29,6 +31,8 @@ prepare() {
ln -sf BambuStudio-${pkgver} BambuStudio
# fix broken udev install reference
patch -p0 < "$srcdir/CMakeLists.txt.patch"
+ # add missing 0001-Boost-fix.patch
+ cp 0001-Boost-fix.patch BambuStudio/deps/Boost
# remove invalid UTF-8 chars
# patch -p0 < "$srcdir/TreeSupport.cpp.patch"
}