summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec844606ee76..b48b7e038990 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
-# Maintainer: Daniel Maslowski <info@orangecms.org>
+# Maintainer: Jonathan Neidel <aur at jneidel dot com>
-_pyname=bandcamp-dl
pkgname=bandcamp-dl-git
-pkgver=v0.0.12.r0.gd35c7ed
+pkgver=v0.0.13.r4.ge21bb65
pkgrel=1
pkgdesc="download audio from BandCamp.com"
arch=('any')
@@ -13,7 +12,7 @@ depends=(
'python'
'python-beautifulsoup4'
'python-chardet'
- 'python-demjson'
+ 'python-demjson3'
'python-docopt'
'python-mock'
'python-mutagen'
@@ -21,22 +20,20 @@ depends=(
'python-unicode-slugify'
'python-setuptools'
)
-provides=("$_pyname")
-conflicts=("$_pyname")
+provides=("${pkgname/-git/}")
+conflicts=("${pkgname/-git/}")
options=(!emptydirs)
-source=(https://github.com/iheanyi/bandcamp-dl.git)
+source=("git+https://github.com/iheanyi/bandcamp-dl.git")
sha512sums=('SKIP')
pkgver() {
- cd "$_pyname"
+ cd "$srcdir/${pkgname/-git/}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$_pyname"
+ cd "$srcdir/${pkgname/-git/}"
sed -i -e 's#json+ld#ld+json#' bandcamp_dl/bandcampjson.py
python setup.py install --root="$pkgdir/" --optimize=1
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE.txt"
}
-
-# vim:set ts=2 sw=2 et: