summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 19 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2619d8442e8f..581f626097a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,32 @@
+_orig_ver=1.14.10
+_orig_patch=
+_orig_fullver=$_orig_ver$_orig_patch
+
pkgname=bandwidth
-pkgver=1.10.4
+pkgver=$_orig_ver${_orig_patch:+.$_orig_patch}
pkgrel=1
pkgdesc="Benchmark memory bandwidth"
arch=('i686' 'x86_64')
url="http://zsmith.co/bandwidth.php"
license=('GPL')
+depends=('freetype2')
makedepends=('nasm')
options=(!makeflags !debug)
-sha256sums=('7bf78fdab03b12516b876678a93cd1191fdcc58d5423ab3e2d0f4e835c78ebf2')
-source=("https://zsmith.co/archives/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('fece39a6dfb10c65033d6d79b2356e9ee714e936862b075ebdabd7277ce914a6')
+source=("https://zsmith.co/archives/${pkgname}-${_orig_fullver}.tar.bz2")
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ cd "${srcdir}/${pkgname}-${_orig_fullver}"
make clean
+ ./configure
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${_orig_fullver}"
+
+ # makefile uses LIB instead of LDFLAGS, and needs to know where OOC is
+ export LIB="${LDFLAGS} -lm OOC/libOOC.a $(pkg-config --libs freetype2)"
if [ "${CARCH}" = "x86_64" ]; then
make -f Makefile-linux-x86_64 bandwidth64
@@ -23,7 +36,7 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_orig_fullver}"
if [ "${CARCH}" = "x86_64" ]; then
install -Dm755 bandwidth64 "${pkgdir}"/usr/bin/bandwidth
else